ezz > edb.* > edb.regneark

 #1  
24.12.2006, 08:16
Temp
Hejsa,

Jeg har et regneark, hvor jeg i kolonne B indtaster en dato, og i kolonne E
indtaster en dataværdi.

Nu vil jeg gerne have en formel, der ligger alle dataværdierne i kolonne E
sammen, for 3 måneder bagud i tiden, fra og med dags dato.
Alså, således at den 17. oktober vises summen fra 17. juli til 17. oktober.

Det er vel noget med =SUM.HVIS(), men jeg kan ikke lige gennemskue, hvordan
formelen skal se ud?

Så skal jeg osse bruge et gennemsnit, men da det ikke er alle dage, der
indtastes data, er jeg nødt til at vide, hvor mange indtastningsdage, som
ovenstående sum er en del af!

Så, her skal jeg vel dividerer den ovennævnte fundne sum med et TÆL.HVIS()
tal, der tæller, hvor mange indtastninger, der er indenfor de sidste 3
måneder.

Men, igen, hvordan???

Nogen, der kan hjælpe, med disse formeler?

vh,

Temp
 #2  
24.12.2006, 12:01
Hans Knudsen
"Temp" <nej> skrev i en meddelelse
news:lu42
[..]
> Nogen, der kan hjælpe, med disse formeler?
>> vh,

> Temp


Hvis du for eksempel indtaster slutdatoen (17-10) i celle H1 og i
I1 indtaster =EDATO(H1;-3) (forudsætter, at du har Analysis Toolpak
installeret). Hvis du ikke har eller ikke ønsker det, så kan du i
stedet for indtaste =DATO(ÅR(H1);MÅNED(H1)-3;DAG(H1))

For at finde summen kan du nu i en tom celle indtaste
=SUMPRODUKT((B1:B365>=I1)*(B1:B365<=H1)*(E1:E365))
og for gennemsnittet
=SUMPRODUKT((B1:B365>=I1)*(B1:B365<=H1)*(E1:E365))/SUMPRODUKT((B1:B365>=I1)*(B1:B365<=H1)*(E1:E365<>0 ))

Med venlig hilsen
Hans
Lignende emner